[lvc-project] [PATCH] drm/amd/display: Remove unused-but-set variable hubp from

Марков Глеб Игоревич markov.gi at npc-ksb.ru
Tue Jun 30 11:29:20 MSK 2026


Понедельник, Июнь 29, 2026 18:47 MSK, Fedor Pchelkin <pchelkin at ispras.ru> писал(а):

> Разовая отправка кучи разношёрстных патчей в течение минуты в
> международное сообщество также не есть очень хорошо.  Нормальный процесс
> - это когда мы обсудили патч во внутреннем списке рассылки и когда он
> готов, то он высылается.  Это происходит постепенно.
> 
> Я к тому, что kernel.org не брезгует баном за единоразовые массовые
> отправки разнообразных писем в их рассылки.
> 
> 
> По поводу текущего патча - он не проходил ревью с нашей стороны.  В
> наименовании патча что-то не очень ясное.  Во-первых, снова образелось
> название.  Во-вторых, каким местом здесь unused-but-set variable?

Согласен, наименование некорректно отражает суть предлагаемых изменений.
Относительно принципа работы и отправки патчей в международное сообщество суть ясна.

Unused-but-set variable оказался в наименовании вследствие ранее открытого обсуждения в ходе
ревью подготовленных исправлений. Некорректно понял предложение с вашей стороны и
переименовал патч вместо изучения возможности удаления *hubp1 и *hubp2 из функций.

Предложение об удалении *hubp1 и *hubp2 вижу нецелесообразным, поскольку вызов 
container_of() предполагает наличие уже валидного, переданного в качестве аргумента в метод
hubp1_is_flip_pending(), то именно наличие макроса TO_DCN10_HUBP() делает проверку на NULL
нелогичной.
В таком случае необходимо избавиться от 2-х проверок на NULL вместо одной (по логике отработки).
Если вы согласны, то патч с предлагаемым исправлением будет отправлен после вашего ответа.




More information about the lvc-project mailing list